Commit 0883a922 authored by poljar's avatar poljar Committed by Hubert Chathi
Browse files

python: Make the typing module a requirement only for old python versions.



Typing is part of standard library from python 3.5 and from python 3.7
onwards trying to install it results in an error.

This patch disables typing installation on python versions that are
newer than 3.5.
Signed-off-by: poljar's avatarDamir Jelić <poljar@termina.org.uk>
parent ad024b33
......@@ -22,6 +22,10 @@ setup(
packages=["olm"],
setup_requires=["cffi>=1.0.0"],
cffi_modules=["olm_build.py:ffibuilder"],
install_requires=["cffi>=1.0.0", "future", "typing"],
install_requires=[
"cffi>=1.0.0",
"future",
"typing;python_version<'3.5'"
],
zip_safe=False
)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment